Linuxslate.com Forums
http://linuxslate.com/cgi-bin/forum/YaBB.pl
Mobile Linux Devices >> Linux on Older Pen Based PC's >> Fujitsu StylisticLT...the ancient one!!!!;D
http://linuxslate.com/cgi-bin/forum/YaBB.pl?num=1243736821

Message started by cg132 on May 30th, 2009, 9:27pm

Title: Fujitsu StylisticLT...the ancient one!!!!;D
Post by cg132 on May 30th, 2009, 9:27pm

Hello!
I'm looking for an answer to my fpit woes and maybe it can be found here.  ;D

Originally, back in 2001 I believe, when I first got my tablet I found the fpit driver from here.  Now years later I was forced to upgrade my distro.  I was using slackware 10.1 and the fpit from linuxslate ran great!  I was amazed at how easy it was setup and how smootly it ran.  After a dd backup of my disk I blanked it and installed the latest slackware distro, 12.2 at this time.  A couple of funny things I've noticed.
1, I cant seem to load the old fpit_drv.o for some reason
2, an xorg version of fpit exists now....wth...how much more confusing....
3, the xorg version barely works....

The new module loads....but it sucks.  The cursor flys around the screen out of control.  So I'm looking for any StylisticLT help i can get.  I originally got my slack10 distro using a guide found at http://www.neurath.org/stylistic_lt_c500/  However I'm thinking the old source code that the original module was built from is needed to try to build a module for this kernel version.  I'm sure thats biting off much more than i can chew but...I'm not sure what to do.  Quite confounded at this point.  Any ideas?

Title: Re: Fujitsu StylisticLT...the ancient one!!!!;D
Post by Administrator on Jul 7th, 2009, 5:45pm

It is unlikely that this will help, but...

Really erratic, random cursor movement is usually caused by the wrong bit rate.

It's actually a really good sign, however.  It means the module is loaded, and that you've got the right serial port, just not the right serial port speed, or the driver you loaded is simply not compatible with that model tablet.

Try setting the baud rate in the x config file, or with the setserial command.

Title: Re: Fujitsu StylisticLT...the ancient one!!!!;D
Post by cg132 on Jul 7th, 2009, 6:17pm

woot a reply!  thanks for the idea, but i am using set serial to give it the proper baud rate that was working on my previous install.  i did notice something funny tho.  when i specify the baud rate in the xorg.conf the cursor doesn't move at all.  my previous system was set up with a baud rate of 115200.  i have set serial specify it during boot up, but when i add it to the xorg.conf bad things happen.   :P

Title: Re: Fujitsu StylisticLT...the ancient one!!!!;D
Post by cg132 on Jul 7th, 2009, 8:15pm

oh wait!  i figured something out!!!!  ;D

i had to add in my xorg.conf

option "Vmin" "1"
option "Vtime" 1"


after looking at the Xorg logs on my backup image i found that they were coming in with a value of 1.  where as on my new install they were coming in at 10!!!  once i fixed that the mouse stopped jumping around... now for the calibration xD

thanks for the stimuli.  you got me looking at it again ^_^

Linuxslate.com Forums » Powered by YaBB 2.1!
YaBB © 2000-2005. All Rights Reserved.