Welcome, Guest. Please Login.
Linuxslate.com Forums

<=== Back to the Linuxslate.com Homepage

Newest Forum Posts

Sep 21st, 2023, 9:23pm
News: Welcome to the linuxslate.com forums. May 2020: Forum registration has been disabled due to recent advancements in bypassing captcha's and the resulting increase in spam on the forums. Registration may be re-enabled at a later date. In the meantime, if you would like to register, please email "john" at this domain, and I will manually create an account for you. Registration is for legitimate and relevant discussion only. Misused accounts will be deleted without warning.

Pages: 1
Hacking the Clover POS tablet (Read 476 times)
Forum Administrator


Posts: 119
Hacking the Clover POS tablet
Jan 23rd, 2023, 7:25pm
Hacking the Original Clover Station POS (C100) tablet.
The Original Clover Station has been considered "End of Life" by Clover Network Inc., and replaced by a number of different hardware POS devices.
Since the Original  Clover Station POS (C100) is no longer supported by Clover, these devices are now found in quantity on the surplus market.
The basic clover hardware is actually pretty nice -- especially for when it was released in 2014.  It consists of a good quality 11.6", 1366x768 Touch Screen Display driven by a NVidia Tegra 3 SOC.  It features 1G of RAM (Which was sufficient for the versions of Android that existed at the time), and 8G of flash.  It runs a customized version of Android 4.2.2.

So can these be converted into a regular tablet, or repurposed for other uses?
Before getting much further into this, I will say that we are dealing with proprietary hardware and software here.
I will also say that I got mine (Tablet only) for $10, and I only got it yesterday.  This will be updated as I learn more.
Much of the Clover Station functionality is actually in the printer.  The printer connects to the "Tablet" (The Clover Touchscreen Display) via a proprietary cable.  The power supply, and breakout to standard ports in all done inside the printer.  The printer is powered by a 24V, 5A Power brick.  In addition to the power jack, and the proprietary interconnect port, the printer also contains 4 standard USB ports, and Ethernet port, and an RJ12 connector that is intended for an optional cash drawer or other accessories.  This may be some sort of serial port.
So in functionality, the Printer contains something similar to a USB travel hub with Ethernet.
The proprietary cable that connects to the Tablet contains the following as far as I can tell:
  • Unregulated Power to the Tablet
  • Two (2) Partial USB ports
  • Ground

More specifically, here is the Pinout of the 12 Pin connector inside the tablet:
Pin 1 is at the bottom in the following picture (near the circle).
1.   +Power
2.   +Power
3.   No Connection (No contact on the Motherboard connector)
4.   USB 1 Data  -
5.   USB 1 Data  +
6.   Ground
7.   USB 2 Data -
8.   USB 2 Data +
9.   Unknown Black Wire (no continuity to ground)
10. Ground
11. Ground
12. Ground
  • All grounds seem to be the same, and the same as chassis/shielding ground.  I have not found any separate ground.
  • The Power supplied to the Display Tablet section seems to be an unregulated or higher voltage.

A Little More About the Power:
I am not sure if the +Power was directly fed from the +24V power brick.  24 Vols seems high. All I can say is that it must be enough to run the 5 VDC Buck converter (Red Square shown in the picture).  Mine starts up at about 6.7 VDC.  At this supply voltage, the tablet section draws about 800mA.  8 to 9 VDC seems to me to be a good supply voltage.
For testing, I soldered a short length of wire to positive side of the filter capacitor that is right next to the interface connector. This prevents damage to the connector.
Back to top
« Last Edit: Feb 23rd, 2023, 9:48pm by Administrator »  

Mobile Linux ?
Got That!
WWW   IP Logged
Forum Administrator


Posts: 119
Re: Hacking the Clover POS tablet
Reply #1 - Feb 23rd, 2023, 10:10pm
I have not worked on this project much since I got it.  Too many other priorities.
With the unit powered as described in the previous post, It does power up and work as a basic tablet, but with the locked-down Clover version of Android 4.2.2.
Thanks to week passwords (PINs), I can actually access 3 user accounts.  (Yes -- One of them was "123456" -- People will never learn.  And Yes -- I know what you (lots of people) ordered from the Food Window at a certain attraction. Roll Eyes.  To be clear, I am not trying to obtain information from or via the device or to use it with another financial company of any sort.  -- My intention is to use it as the screen for the Telepresence  Robot described here. )
I have not connected it to the internet yet, because I don't want it "Phoning Home".  I have connected it to an isolated 802.11 network created by a OpenWRT router.
So far, I have not been able to install additional software, or remove the Clover-specific APK's.
-- Blluetooth transfer of .apk files is not allowed.
-- Since there is no file manager, renaming an apk with another extension, sending it, and naming it back to .apk, is not a work-around.
-- I was not able to download an apk by putting it on the OpenWRT router and downloading it.  This is also blocked in the browser (A hardened version of Firefox for Android.)
-- The developer options does not work, so there does not seem to be a way to enable ADB.  I have not tried to connect to ADB via either USB port.
-- USB drives connected to the 1st USB port are not recognized in the normal manner.
-- Connecting a USB hub to USB port 1 creates 4 mount points for USB storage devices, each tied to a specific port on the hub, however, in my brief attempts, I could not get a USB storage device to actually mount.
-- USB port 1 does not appear in lsusb when the Clover tablet is connected to a PC.
Next steps:
-- Try a different hub.
-- Try different USB storage devices.
-- Try the Other USB port.
Back to top
« Last Edit: Apr 23rd, 2023, 8:51pm by Administrator »  

Mobile Linux ?
Got That!
WWW   IP Logged
Pages: 1